SharePoint App Catalog Issues

Modified on Wed, 2 Aug, 2023 at 8:16 PM

Symptom:

You are attempting to install Torsion as an app in SharePoint Online or Microsoft Teams, but the installation fails, and you receive an error message indicating that an app catalog is required.


Cause:

The absence of an app catalog in your SharePoint Online tenant is preventing you from installing Torsion. An app catalog is a special site collection that is used to store and distribute apps for SharePoint and Microsoft Teams.


Solution:

To install Torsion as an app in SharePoint Online or Microsoft Teams, you must first create an app catalog in your SharePoint Online tenant. Here are the steps to follow:


Sign in to the Microsoft 365 admin center with your administrator account.
Select the "Show all" option to see all available admin centers.
Click on "SharePoint" to open the SharePoint admin center.
In the SharePoint admin center, click on "More features" in the left-hand menu, and then select "Apps".
On the Apps page, click on "App Catalog" and then click on "Create a new app catalog site".
Fill out the required fields and then click on "OK" to create the app catalog.
Once you have created the app catalog, you can proceed with installing Torsion. Note that the user installing the app must have the necessary permissions to install apps in the SharePoint Online tenant, which may require additional configuration or permissions changes in the SharePoint Online tenant.


In summary, if you receive an error message indicating that an app catalog is required when attempting to install Torsion, the solution is to create an app catalog in your SharePoint Online tenant before proceeding with the installation.

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article